User Tools

Site Tools


manual:faq:devices_older_android

Older versions of Locus Map


Downgrade

  • “the newest version doesn't work as I've expected. I want to downgrade.”

Recent versions of Locus Map

Older Android OS

  • “I would like to install your app but I have a device with an older Android version that is not supported by the current Locus Map available in Google Play Store.”

The reason for this incompatibility is the permanent development of the Locus application and the Android itself as well. Some functions simply cannot be developed for older Android devices.

The solution is to install the latest Locus Map version that supports your version of Android.

Instructions

Locus Map Pro

To use an older Locus Map Pro, you have to purchase a license for Locus Map Classic. Please do so in the Google Play Store in an Android emulator on your PC, running Android higher than 5.0 (e.g. Bluestacks) - the license validation will work for the old Locus Map Pro as well.

  • enable installation from other sources than Google Play Store in your device (usually in settings > security or device management)
  • download .APK file supported by your Android version and install:

Android 4.4.4. - 4.1.

Android 4.0.4.- 4.0.3.

Android 4.0.2. - 2.4

Android 2.3.x - 2.2.x

Android PIT AppStore - necessary for Android PIT customers who want to use Locus 3.5.3 (last functional for Android PIT). Android PIT store was terminated in 2014.

Android 2.1 and older

manual/faq/devices_older_android.txt · Last modified: 2022/04/12 18:21 by mstupka